Sugestie dotyczące forum, systemu WinduCMS 2 oraz inne tematy.

Moderator: Moderatorzy

[Problem] Długie czasy odpowiedzi Windu

Postprzez maximus-75 » 06 Mar 2013, 01:29

Witam,

Po wpisaniu adresu strony głownej czas odpowiedzi windu to 15-30 sek. Czasami wogóle nie mogę się połączyć ze stroną. Logujac sie jako admin nie można kompletnie nic zrobić. Często pokazuje mie się błąd 502 ale czas samego ładowania stronu to 1-2 sek.

Ładuje podstrone z poza systemu wszystko jest ok. Czas odpowiedzi serwera to 0.4 ms i szybkie pobieranie.


Cache włączone. Jest własnie godzina 1.30 w nocy i nadal ten sam problem. W configu nic nie zmieniałem.


Z góry dzięki za pomoc.
Pozdrawiam, MAXimus
maximus-75
Adept
 
Posty: 16
Rejestracja: 26 Lut 2013, 16:04
Podziękował: 4 razy
Pomagał(a): 0 raz(y)

Re: Długie czasy odpowiedzi Windu

Postprzez czajnik » 06 Mar 2013, 09:17

Przy pierwszym ładowaniu strony danego dnia system robi analize statystyk oraz zapisuje jej wyniki w bazie, to wymaga łączenia z innymi serwerami takimi jak serwery google od pr i alexa, ponadto przy pierwszym ładowaniu strony generowane są pliki z cache, potem strona powinna chodzić błyskawicznie. Pytanie jak jest póżniej?
czajnik
Administrator
 
Posty: 1108
Rejestracja: 26 Lut 2010, 02:56
Podziękował: 64 razy
Pomagał(a): 243 razy

Re: Długie czasy odpowiedzi Windu

Postprzez maximus-75 » 06 Mar 2013, 10:13

Nie ma znaczenia. Mogę logować się i odwiedzać stronę kikladziesiąt razy efekt jest identyczny. Ale gdy wczytanie strony trwa ok. 15-20 sek. to logowanie do admina ok 1 min. W systemie teraz pojawił mi się błąd "SQLSTATE[HY000]: General error: 5 database is locked". Pytanie jest jakich parapetrów Windu wymaga od serwera aby poprawnie działać. Móje WINDU generuje 8 procesów PHP co podobno nie jest normalne i może wpływać na prace serwera gdzie przy koncie personal może to mieć znaczenie.
maximus-75
Adept
 
Posty: 16
Rejestracja: 26 Lut 2013, 16:04
Podziękował: 4 razy
Pomagał(a): 0 raz(y)

Re: Długie czasy odpowiedzi Windu

Postprzez czajnik » 06 Mar 2013, 11:03

Mogę prosić o linka do strony?
czajnik
Administrator
 
Posty: 1108
Rejestracja: 26 Lut 2010, 02:56
Podziękował: 64 razy
Pomagał(a): 243 razy

Re: Długie czasy odpowiedzi Windu

Postprzez maximus-75 » 06 Mar 2013, 11:09

i-windo.co.uk. Aktulany czas ładowania strony pomiędzy 13-57 sek w zateżności od testu.
Ostatnio edytowany przez maximus-75, 06 Mar 2013, 11:18, edytowano w sumie 1 raz
maximus-75
Adept
 
Posty: 16
Rejestracja: 26 Lut 2013, 16:04
Podziękował: 4 razy
Pomagał(a): 0 raz(y)

Re: Długie czasy odpowiedzi Windu

Postprzez czajnik » 06 Mar 2013, 11:14

Faktycznie coś jest nei tak... Co to za serwer? Generalnei nawet na lokalnym pentiumie 600 windu chodzi błyskawicznie :P więc nie wiem jak mało wydajna musi być tamta maszyna... Myślałeś nad zmianą usługodawcy?
czajnik
Administrator
 
Posty: 1108
Rejestracja: 26 Lut 2010, 02:56
Podziękował: 64 razy
Pomagał(a): 243 razy

Re: Długie czasy odpowiedzi Windu

Postprzez maximus-75 » 06 Mar 2013, 11:21

Hosting personal na az.pl ale czekam na zmiane na hosting business do testów. Samo pobieranie strony głównej jak i czas odpowiedzi i pobieranie jej elemtów trwa mnie niż 2 sek. Problemem jest tylko czas między zapytaniem do serwera a momentem kiedy serwer zaczyna wysyłać dane

Image
Ostatnio edytowany przez maximus-75 06 Mar 2013, 11:46, edytowano w sumie 2 razy
maximus-75
Adept
 
Posty: 16
Rejestracja: 26 Lut 2013, 16:04
Podziękował: 4 razy
Pomagał(a): 0 raz(y)

Re: Długie czasy odpowiedzi Windu

Postprzez czajnik » 06 Mar 2013, 11:26

Generalnie tearz jeszcze poprawiamy wydajność no ale na słabych hostingach chodzi szybko wiec nie wiem czmeu tak :/
czajnik
Administrator
 
Posty: 1108
Rejestracja: 26 Lut 2010, 02:56
Podziękował: 64 razy
Pomagał(a): 243 razy

Re: Długie czasy odpowiedzi Windu

Postprzez maximus-75 » 06 Mar 2013, 12:34

Nic nie pomogła zmiana na hosting business teraz przy ładowaniu strony komunikat SQLSTATE[HY000]: General error: 5 database is locked
maximus-75
Adept
 
Posty: 16
Rejestracja: 26 Lut 2013, 16:04
Podziękował: 4 razy
Pomagał(a): 0 raz(y)

Re: Długie czasy odpowiedzi Windu

Postprzez maximus-75 » 06 Mar 2013, 13:33

Tu komunikat przy próbie zapisu którkiej informacji w notatniku

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000]: General error: 5 database is locked' in /home/mba57174/public_html/app/plugins/database/baseDB.class.php:141 Stack trace: #0 /home/mba57174/public_html/app/plugins/database/baseDB.class.php(141): PDOStatement->execute(Array) #1 /home/mba57174/public_html/app/plugins/database/baseDB.class.php(103): baseDB->_insertOneRow(Array) #2 /home/mba57174/public_html/app/model/logDB.class.php(23): baseDB->insert(Array) #3 /home/mba57174/public_html/app/model/logDB.class.php(16): logDB->insert(Array) #4 /home/mba57174/public_html/app/core/log.class.php(7): logDB->add(99, Array) #5 /home/mba57174/public_html/front.php(37): log::write('SQLSTATE[HY000]...', 99) #6 {main} thrown in /home/mba57174/public_html/app/plugins/database/baseDB.class.php on line 141
maximus-75
Adept
 
Posty: 16
Rejestracja: 26 Lut 2013, 16:04
Podziękował: 4 razy
Pomagał(a): 0 raz(y)


Kto jest na forum

Użytkownicy przeglądający to forum: Brak zarejestrowanych użytkowników oraz 1 gość

cron