Pytania, problemy związane z językiem HTML oraz stylami CSS

Moderator: Moderatorzy

Błąd ładowania css i js

Postprzez allahu_akbar » 23 Lis 2014, 16:38

Cześć.

Mam dziwny problem, mianowicie Windu z jakiegoś powodu przestało poprawnie ładować niektóre (dla mnie kluczowe) css-y. Co najciekawsze, problem pojawił się dopiero PO wrzuceniu właściwej treści strony poprzez panel Windu - dopóki pracowałem na lorem ipsum, wszystko było cacy. Ale do rzeczy.

Kod templatki tpl_main/main.tpl:
Kod: Zaznacz wszystko
...
{{foreach resourceManager::loadFrontCSS() as $cssFile}}
   <link rel='stylesheet' type='text/css' href='{{$cssFile}}'>
{{/foreach}}...


...generuje mi wyjściowego HTMLa w postaci:
Kod: Zaznacz wszystko
<link rel='stylesheet' type='text/css' href='http://serwer1470153.home.pl/rtc/data/themeshttp://serwer1470153.home.pl/rtc/css/bootstrap-extends.css?ver=149'>
<link rel='stylesheet' type='text/css' href='http://serwer1470153.home.pl/rtc/data/themeshttp://serwer1470153.home.pl/rtc/css/bootstrap.min.css?ver=149'>
<link rel='stylesheet' type='text/css' href='http://serwer1470153.home.pl/rtc/data/themeshttp://serwer1470153.home.pl/rtc/css/main.css?ver=149'>


DAFUQ?

Widzimy tutaj, że wstawiany jest adres serwera pomiędzy
Kod: Zaznacz wszystko
themes
a
Kod: Zaznacz wszystko
rtc
Poprawna ścieżka do pliku to:
http://serwer1470153.home.pl/rtc/data/themes/rtc/css/main.css?ver=149

To samo dotyczy niektórych plików .js

Any ideas?
allahu_akbar
 
Posty: 1
Rejestracja: 23 Lis 2014, 16:28
Podziękował: 0 raz(y)
Pomagał(a): 0 raz(y)

Re: Błąd ładowania css i js

Postprzez rwd5 » 24 Lis 2014, 15:14

Błędnie jakoś ścieżka działa :/
1) Zobacz, czy w panelu administracyjnym w konfiguracja->ogólne->systemDir masz ustawiony katalog, gdzie znajduje się windu na w Twoim przypadku: "/rtc/"
2) Może została skeszowana jakimś nachalnym oprogroamowanie od hostingu, chociaż na homie to się nie zdarzało :/ Wyczyść i sprawdź czy dalej nie działa.

Pozdrawiam
Sebastian Miecielica | windu.org
rwd5
Weteran
 
Posty: 683
Rejestracja: 27 Lut 2011, 12:55
Miejscowość: Warszawa
Podziękował: 32 razy
Pomagał(a): 256 razy

Re: Błąd ładowania css i js

Postprzez kun » 24 Lis 2014, 15:53

Współpacuję z kolegą przy tej stronie. Istotnie celowaliśmy w zły katalog nie mniej po wprowadzeniu zmiany i oczywiście zwolnieniu catcha nie widzę zmian.

Przykład link do zdjęcia wygenerowany przez system: http://serwer1470153.home.pl/rtc/%7B%7B$HOME%7D%7Dimage/dcwjrbwjvagj/940/626/original/

Wszystkie usługi home.pl są wyłączone.
kun
Adept
 
Posty: 13
Rejestracja: 30 Maj 2014, 10:32
Podziękował: 1 raz(y)
Pomagał(a): 0 raz(y)

Re: Błąd ładowania css i js

Postprzez rwd5 » 24 Lis 2014, 22:21

Wow, odkryłem małego bug'a jeśli nazwa katalogu w którym znajduje się windu jest taka sama jak szablony graficzny mogą wystąpić problemy, także proszę zmieniać nazwę szablonu graficznego na bardziej wymyślny.
rwd5
Weteran
 
Posty: 683
Rejestracja: 27 Lut 2011, 12:55
Miejscowość: Warszawa
Podziękował: 32 razy
Pomagał(a): 256 razy


Kto jest na forum

Użytkownicy przeglądający to forum: Brak zarejestrowanych użytkowników oraz 1 gość

cron